Ejercicios con estructura repetitiva Repetir_Hasta en Pseint – parte 3

Diseña un algoritmo que pida al usuario ingresar números enteros uno por uno hasta que ingrese cero. Luego, muestra la suma de los números pares y la suma de los números impares utilizando la estructura “repetir_hastaque”.

Peudocódigo

				
					Proceso SumaNumerosParesImpares
	Definir numero, sumaPares, sumaImpares como Entero
	sumaPares <- 0
	sumaImpares <- 0
	
	Repetir
		Escribir "Ingrese un número entero (ingrese 0 para terminar): "
		Leer numero
		Si numero <> 0 Entonces
			Si numero % 2 = 0 Entonces
				sumaPares <- sumaPares + numero
			Sino
				sumaImpares <- sumaImpares + numero
			FinSi
		FinSi
	Hasta Que numero = 0
	
	Escribir "La suma de los números pares es: ", sumaPares
	Escribir "La suma de los números impares es: ", sumaImpares
FinProceso
				
			

Ejercicio 3.2: Números Primos

Diseña un algoritmo que solicite al usuario ingresar un número entero positivo y determine si es un número primo o no. Un número primo es aquel que solo es divisible por 1 y por sí mismo.

Peudocódigo

				
					Proceso NumerosPrimos
	Definir numero, i, contador como Entero
	contador <- 0
	
	Repetir
		Escribir "Ingrese un número entero positivo mayor que 1: "
		Leer numero
	Hasta Que numero > 1
	
	i <- 1
	Repetir
		Si numero % i = 0 Entonces
			contador <- contador + 1
		FinSi
		i <- i + 1
	Hasta Que i > numero
	
	Si contador = 2 Entonces
		Escribir numero, " es un número primo."
	Sino
		Escribir numero, " no es un número primo."
	FinSi
FinProceso
				
			

Ejercicio 3.3: Suma de Fracciones

Diseña un algoritmo que solicite al usuario ingresar un número entero positivo “n” y luego calcule la suma de las primeras “n” fracciones utilizando la fórmula: 1/1 + 1/2 + 1/3 + … + 1/n.

Peudocódigo

				
					Proceso SumaDeFracciones
	Definir n, i como Entero
	Definir suma como Real
	Definir textoSalida como Caracter
	
	Repetir
		Escribir "Ingrese un número entero positivo: "
		Leer n
	Hasta Que n > 0
	
	suma <- 0
	i <- 1
	Repetir
		textoSalida <- textoSalida  + "1/" + ConvertirATexto(i)
		Si i < n Entonces
			textoSalida <- textoSalida + " + "
		FinSi
		
		suma <- suma + 1 / i
		i <- i + 1
	Hasta Que i > n
	
	Escribir "La suma de las primeras ", n, " fracciones es "
	Escribir textoSalida " = ", suma
FinProceso
				
			

Ejercicio 3.4: Generación de números primos

Diseña un algoritmo que genere y muestre los primeros N números primos, donde N es un número ingresado por el usuario.

Peudocódigo

				
					Proceso GenerarPrimos
	Definir N, contadorPrimos, numero, i, contadorDivisores como Entero
	
	Repetir
		Escribir "Ingrese la cantidad de números primos que desea generar: "
		Leer N
	Hasta Que N > 0
		
	contadorPrimos <- 0
	numero <- 2
	Escribir "Los primeros ", N, " números primos son:"
	
	Repetir
		contadorDivisores <- 0
		Para i <- 1 Hasta numero Hacer
			Si numero % i = 0 Entonces
				contadorDivisores <- contadorDivisores + 1
			FinSi
		FinPara
		
		Si contadorDivisores = 2 Entonces
			contadorPrimos <- contadorPrimos + 1
			Escribir numero
		FinSi
		
		numero <- numero + 1
		
	Hasta Que contadorPrimos >= N
	
FinProceso
				
			

Deja una respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Puedes usar estos tags HTML y atributos: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>