Ejercicios con estructura repetitiva Repetir_Hasta en Pseint – parte 2

Diseña un algoritmo que pida al usuario ingresar números enteros positivos uno por uno hasta que ingrese un número negativo. Luego, muestra la suma de los números ingresados.

Peudocódigo

				
					Proceso SumaDeNumeros
	Definir numero, suma como Entero
	suma <- 0
	
	Repetir
		Escribir "Ingrese un número entero positivo (ingrese un número negativo para terminar): "
		Leer numero
		Si numero >= 0 Entonces
			suma <- suma + numero
		FinSi
	Hasta Que numero < 0
	
	Escribir "La suma de los números ingresados es:", suma
FinProceso
				
			

Ejercicio 2.2: Factorial

Diseña un algoritmo que solicite al usuario ingresar un número entero positivo y luego calcule su factorial utilizando la estructura “repetir_hastaque”.

Peudocódigo

				
					
Proceso Factorial
	Definir n, facto como Entero
	facto <- 1
	
	Repetir
		Escribir "Ingrese un número entero positivo: "
		Leer n
	Hasta Que n > 0
	
	Repetir
		facto <- facto * n
		n <- n - 1
	Hasta Que n <= 0
	
	Escribir "El factorial es:", facto
FinProceso
				
			

Ejercicio 2.3: Tabla de Multiplicar

Diseña un algoritmo que solicite al usuario ingresar un número y luego muestre su tabla de multiplicar desde 1 hasta 12 utilizando la estructura “repetir_hastaque”.

Peudocódigo

				
					Proceso TablaDeMultiplicar
	Definir numero, i como Entero
	
	Escribir "Ingrese un número: "
	Leer numero
	i <- 1
	
	Repetir
		resultado <- numero * i
		Escribir numero, " x ", i, " = ", resultado
		i <- i + 1
	Hasta Que i > 12
FinProceso
				
			

Ejercicio 2.4: Adivinar el Número

Diseña un algoritmo que genere un número aleatorio entre 1 y 100 y permita al usuario adivinar el número. Utiliza la estructura “repetir_hastaque” hasta que el usuario adivine correctamente. Muestra el número de intentos necesarios para adivinarlo.

Peudocódigo

				
					Proceso AdivinarNumero
	Definir random, adivinanza, intentos como Entero
	random <- Aleatorio(1, 100)
	intentos <- 0
	
	Repetir
		Escribir "Adivina el número (entre 1 y 100): "
		Leer adivinanza
		intentos <- intentos + 1
		
		Si adivinanza < random Entonces
			Escribir "El número es mayor."
		Sino Si adivinanza > random Entonces
				Escribir "El número es menor."
			Sino
				Escribir "¡Correcto! Has adivinado el número en ", intentos, " intentos."
			FinSi
		FinSi
	Hasta Que adivinanza = random
FinProceso
				
			

Explicación

Este programa genera un número aleatorio entre 1 y 100 y luego permite al usuario adivinar el número. El programa brinda pistas al usuario diciendo si el número a adivinar es mayor o menor que el número propuesto por el usuario. El juego continúa hasta que el usuario adivina correctamente el número aleatorio, momento en el que se muestra la cantidad de intentos que le llevó al usuario adivinarlo.

Variables utilizadas:

  • random: Almacena el número aleatorio generado entre 1 y 100.
  • adivinanza: Almacena el número propuesto por el usuario en su intento de adivinanza.
  • intentos: Lleva un registro de la cantidad de intentos que ha realizado el usuario.

Pasos del Proceso:

  1. Se genera un número aleatorio random utilizando la función Aleatorio(1, 100). Este número es desconocido para el usuario y es el que debe adivinar.
  2. Se inicia la variable intentos en 0 para llevar un registro de la cantidad de intentos del usuario.
  3. Se entra en un bucle “repetir” que se ejecuta mientras adivinanza sea diferente de random, es decir, hasta que el usuario adivine el número correcto.
  4. Dentro del bucle, el programa solicita al usuario que ingrese su suposición mediante la línea Escribir "Adivina el número (entre 1 y 100): " y luego lee la suposición del usuario en la variable adivinanza.
  5. Se incrementa el contador de intentos en 1 para llevar un registro de los intentos realizados por el usuario.
  6. Luego, el programa compara la suposición del usuario adivinanza con el número aleatorio random.
  7. Si adivinanza es menor que random, el programa muestra “El número es mayor.”
  8. Si adivinanza es mayor que random, el programa muestra “El número es menor.”
  9. Si adivinanza es igual a random, significa que el usuario adivinó el número correcto, por lo que muestra “¡Correcto! Has adivinado el número en intentos intentos.” y termina el bucle.
  10. Una vez que el usuario adivina el número, el programa muestra la cantidad total de intentos que tomó adivinarlo.

Deja una respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Puedes usar estos tags HTML y atributos: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>